Funções de Localização no Excel – PROCV, PROCH, ÍNDICE e CORRESP

Neste artigo vou te passar uma aula com as principais funções de localização de dados do Excel – PROCV, PROCH, ÍNDICE e CORRESP (o procv ao contrário). Assim você poderá montar diversas consultas independente de como está montada a matriz de dados.

funções de localização

Uma das maiores necessidades na criação de consultas é a de funções que busquem informações de um registro específico. Para te ajudar nesse momento, escolhi 4 funções que, provavelmente, irão te ajudar em 90% dos casos: PROCV, PROCH, Índice e Corresp. Aqui separei um tópico para falar de cada uma dessas funções, espero que aproveite!



Funções de Localização: PROCV

O Excel possui centenas de recursos e funções úteis destinadas à resolver as mais diversas situações, mas algumas dessas funções se destacam por serem as mais usuais. Um desses destaques é o famoso, e até um pouco temido, PROCV. Ele é um recurso que nos ajuda a automatizar consultas, já que busca informações de um lançamento bastando que se informe alguns argumentos.

FUNÇÃO:

=PROCV(VALOR_PROCURADO;MATRIZ_TABELA;NÚM_ÍNDICE_COLUNA;[PROCURA_INTERVALO])

  • VALOR_PROCURADO –  Insira aqui o valor que você quer procurar ou coloque o endereço da célula onde está o valor.
  • MATRIZ_TABELA –  Selecione o intervalo de dados completo onde será feita a consulta. O nome procurado deve estar na primeira primeira coluna da seleção.
  • NÚM_ÍNDICE_COLUNA –  Informe o número corresponde à coluna de onde deve vir a consulta. Você sempre deve considerar a contagem da primeira coluna para a direita, onde a primeira é a coluna 1.
  • PROCURA_INTERVALO –  Aqui você pode optar por uma procura aproximada do termo (VERDADEIRO ou 1) ou a procura exata do termo (FALSO ou 0).

EXEMPLO:

Exemplo de PROCV

  • Fórmula 1: =PROCV($H$4;$B$4:$E$9;2;0)
  • Fórmula 2: =PROCV($H$4;$B$4:$E$9;3;0)
  • Fórmula 3: =PROCV($H$4;$B$4:$E$9;4;0)

OBSERVAÇÕES:

  • Pontos fortes: Função rápida de montar
  • Pontos fracos: A informação a ser buscada precisa estar na primeira coluna e a tabela deve estar no formato vertical, isso é, as variáveis estão na primeira linha e os lançamentos são feitos em cada linha.  Se houver registro duplicado, a busca trará apenas o primeiro registro encontrado.

 

Funções de Localização: PROCH

O PROCH é muito semelhante ao PROCV e é utilizado quando a tabela de dados está na posição horizontal, isso é, as variáveis estão na primeira coluna e os lançamentos são feitos em cada coluna.

FUNÇÃO:

=PROCH(VALOR_PROCURADO;MATRIZ_TABELA;NÚM_ÍNDICE_COLUNA;[PROCURA_INTERVALO])

  • VALOR_PROCURADO –  Insira aqui o valor que você quer procurar ou coloque o endereço da célula onde está o valor.
  • MATRIZ_TABELA –  Selecione o intervalo de dados completo onde será feita a consulta. O nome procurado deve estar na primeira linha da seleção.
  • NÚM_ÍNDICE_LINHA –  Informe o número corresponde à linha de onde deve vir a consulta. Você sempre deve considerar a contagem da primeira linha para baixo, onde a primeira é a linha 1.
  • PROCURA_INTERVALO –  Aqui você pode optar por uma procura aproximada do termo (VERDADEIRO ou 1) ou a procura exata do termo (FALSO ou 0).

EXEMPLO:

Exemplo de PROCH

  • Fórmula 1: =PROCH($E$7;$D$2:$I$5;2;0)
  • Fórmula 2: =PROCH($E$7;$D$2:$I$5;3;0)
  • Fórmula 3: =PROCH($E$7;$D$2:$I$5;4;0)

OBSERVAÇÕES:

  • Pontos fortes: Função rápida de montar
  • Pontos fracos: A informação a ser buscada precisa estar na primeira linha e a tabela deve estar no formato hotizontal, isso é, as variáveis estão na primeira coluna e os lançamentos são feitos em cada coluna.  Se houver registro duplicado, a busca trará apenas o primeiro registro encontrado.

 

Funções de Localização: CORRESP + ÍNDICE

O ÍNDICE é uma ferramenta muito versátil de localização pois basta que se informe a matriz de dados, o número da coluna e o número da linha da matriz, e ele trás o valor do cruzamento. Só isso já seria incrível, mas para tornar tudo ainda mais automático, incorporamos a função CORRESP que pode fornecer tanto o número da coluna que se quer, quanto da linha.

FUNÇÃO:

=ÍNDICE(MATRIZ;NÚM_LINHA;NÚM_COLUNA)

  • MATRIZ –  Selecione a matriz de dados.
  • NÚM_LINHA –  Informe o número da linha na matriz onde está o dado.
  • NÚM_COLUNA – Informe o número da coluna na matriz onde está o dado.

=CORRESP(VALOR_PROCURADO;MATRIZ_TABELA;TIPO_CORRESPONDÊNCIA)

  • VALOR_PROCURADO – Insira aqui o valor que você quer procurar ou coloque o endereço da célula onde está o valor.
  • MATRIZ_TABELA –  Selecione a coluna ou linha onde será feita a busca do VALOR_PROCURADO.
  • TIPO_CORRESPONDÊNCIA – Aqui você pode optar por uma procura aproximada do termo (VERDADEIRO ou 1) ou a procura exata do termo (FALSO ou 0).

Juntando os dois:

=ÍNDICE(MATRIZ;CORRESP(VALOR_PROCURADO;MATRIZ_TABELA;TIPO_CORRESPONDÊNCIA);CORRESP(VALOR_PROCURADO;MATRIZ_TABELA;TIPO_CORRESPONDÊNCIA))

  • MATRIZ –  Selecione a matriz de dados.
  • NÚM_LINHA
    • VALOR_PROCURADO – Insira aqui o valor do termo que você quer procurar para te informar a linha.
    • MATRIZ_TABELA – Selecione a coluna onde será feita a busca do VALOR_PROCURADO.
    • TIPO_CORRESPONDÊNCIA – Aqui você pode optar por uma procura aproximada do termo (VERDADEIRO ou 1) ou a procura exata do termo (FALSO ou 0).
  • NÚM_COLUNA
    • VALOR_PROCURADO – Insira aqui o valor do termo que você quer procurar para te informar a coluna.
    • MATRIZ_TABELA – Selecione a linha onde será feita a busca do VALOR_PROCURADO.
    • TIPO_CORRESPONDÊNCIA  – Aqui você pode optar por uma procura aproximada do termo (VERDADEIRO ou 1) ou a procura exata do termo (FALSO ou 0).

EXEMPLO:

Exemplo de Índice e Corresp

Tabela 1

  • Fórmula 1: =ÍNDICE($B$2:$E$8;CORRESP($K$4;$C$2:$C$8;0);CORRESP($J3;$B$2:$E$2;0))
  • Fórmula 2: =ÍNDICE($B$2:$E$8;CORRESP($K$4;$C$2:$C$8;0);CORRESP($J5;$B$2:$E$2;0))
  • Fórmula 3: =ÍNDICE($B$2:$E$8;CORRESP($K$4;$C$2:$C$8;0);CORRESP($J6;$B$2:$E$2;0))Tabela 2
  • Fórmula 1: =ÍNDICE($B$10:$H$13;CORRESP($J10;$B$10:$B$13;0);CORRESP($K$12;$B$12:$H$12;0))
  • Fórmula 2: =ÍNDICE($B$10:$H$13;CORRESP($J11;$B$10:$B$13;0);CORRESP($K$12;$B$12:$H$12;0))
  • Fórmula 3: =ÍNDICE($B$10:$H$13;CORRESP($J13;$B$10:$B$13;0);CORRESP($K$12;$B$12:$H$12;0))

OBSERVAÇÕES:

  • Pontos fortes: Pode fazer localização para todas as direções.
  • Pontos fracos: A função fica grande. Se houver registro duplicado, a busca trará apenas o primeiro registro encontrado.

Download da Planilha de Exemplo

 

Vídeo-aula: Funções de Localização no Excel – PROCV, PROCH, ÍNDICE e CORRESP

 

Agora é sua vez!

Comenta aí se a aula te ajudou ou se ficou alguma dúvida.

Com a sua participação, o blog cresce!

Assista também nossas aulas no canal: Tudo com Excel

Curta nossa fanpage no Facebook

Works with AZEXO page builder